Diablo 3 beta stuck updating setup files jobs with dating services

What I did: Run launcher, it'll stick at 60% Open Task Manager and Kill Open C: Program Data/Battle.net/Agent/Agent.868 Run Agent. I uninstalled it, and now I can't even install it again!

Exe from this folder before it restarts itself in task manager (A DOS window will appear, let it run all the way, it will close itself) Once it finishes, the Launcher will die. Note, I ran Agent.524 first, not sure if that is a pertinent step or not, if it is, insert it before Agent.868. After trying all of the options posted to no avail, I started fiddling with it myself. But as the shadow once again crawls across our world... I tried everything, from killing Agent.exe, renaming it, deleting folder, and I still can't get it to start.

If this works for you guys can you add it to the forums? What I did: Run launcher, it'll stick at 60% Open Task Manager and Kill Open C: Program Data/Battle.net/Agent/Agent.868 Run Agent. and the stench of terror drifts on a bitter wind... It just sits there with "Updating setup files...." and that's it.

It switches between "updating setup files" and "launching blizzard launcher" for a good hour and a half now... I did an integrity check aka ran the installer peer to peer loader and it checked all the files and it was fine...

Trying to dl the beta right now but it is stuck on "Updating setup files", and has been for about 5 minutes.

I remember reading something before about some agents or something a while back but can't find the threads and not sure if that's my problem. well i havnt really encountered that problem once i started it in admin mode. Maybe there is some feedback to be found on the tech forums on offical d3 forums.

But im rather lazy atm so cba looking it up for you! After trying all of the options posted to no avail, I started fiddling with it myself.

That is, after deleting them before trying it again. Starting over with trying to mark Updaters as well for Combability Mode.

The Launcher is now happily updating my files as it normally does on a Patch.

I had let the thing loop around for 4 hours with no progress, I let the other installer run over night, I was so excited, when i hit finished (since I could actually see a typical blizzard launcher type thing) and it went RIGHT BACK to same spot and started looping through again.

If this works for you guys can you add it to the forums? Try rebooting the system into 'Safe Mode with Networking' (mash on F8 just before the windows logo comes up). After that, the update will most likely freeze, if it does reboot back to normal mode. Start the manually, but before it restarts on its own. and the stench of terror drifts on a bitter wind...

Next time you run the launcher it should skip the 'Updating Tools' part and begin downloading the patch/update whatever it happens to be. EDIT: I would like to add that I personally have not had this issue since the last tools update (the one a few days ago, not patch 16). But as the shadow once again crawls across our world... This will open the DOS-like program that needs to stay opened through the whole installation. Once the game is installed, you can play with no trouble at all.

478 Comments

  1. What I did: Run launcher, it'll stick at 60% Open Task Manager and Kill Open C: Program Data/Battle.net/Agent/Agent.868 Run Agent. I uninstalled it, and now I can't even install it again!

  2. Exe from this folder before it restarts itself in task manager (A DOS window will appear, let it run all the way, it will close itself) Once it finishes, the Launcher will die. Note, I ran Agent.524 first, not sure if that is a pertinent step or not, if it is, insert it before Agent.868. After trying all of the options posted to no avail, I started fiddling with it myself. But as the shadow once again crawls across our world... I tried everything, from killing Agent.exe, renaming it, deleting folder, and I still can't get it to start.

  3. If this works for you guys can you add it to the forums? What I did: Run launcher, it'll stick at 60% Open Task Manager and Kill Open C: Program Data/Battle.net/Agent/Agent.868 Run Agent. and the stench of terror drifts on a bitter wind... It just sits there with "Updating setup files...." and that's it.

  4. Exe from this folder before it restarts itself in task manager (A DOS window will appear, let it run all the way, it will close itself) Once it finishes, the Launcher will die. Note, I ran Agent.524 first, not sure if that is a pertinent step or not, if it is, insert it before Agent.868. What if this same issue appears with the full game? Whenever you start the install, first wait for to appear in the Processes tab in Task Manager, then kill it. But as the shadow once again crawls across our world...

  5. It switches between "updating setup files" and "launching blizzard launcher" for a good hour and a half now... I did an integrity check aka ran the installer peer to peer loader and it checked all the files and it was fine...

  6. Trying to dl the beta right now but it is stuck on "Updating setup files", and has been for about 5 minutes.

  7. I remember reading something before about some agents or something a while back but can't find the threads and not sure if that's my problem. well i havnt really encountered that problem once i started it in admin mode. Maybe there is some feedback to be found on the tech forums on offical d3 forums.

  8. But im rather lazy atm so cba looking it up for you! After trying all of the options posted to no avail, I started fiddling with it myself.

Comments are closed.